Настройка маршрутизации между vlan cisco

Записки и примеры конфигов

Модератор: ROOT

Настройка маршрутизации между vlan cisco

Сообщение ROOT » 09 авг 2013, 10:04

Задача: настроить маршрутизацию между сетями разных VLAN.

Настройка Cisco Catalyst-3560 (L3 switch):

1)Зададим IP – адрес коммутатору:
Код: выделить все
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)# no shutdown


2)Создадим vlan-ы:

Код: выделить все
Switch(config)#vlan 2
Switch(config-vlan)#name net2
Switch(config)#vlan 3
Switch(config-vlan)#name net3


3)Создадим vlan – интерфейсы:

Код: выделить все
Switch(config)#interface vlan 2
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config)#interface vlan 3
Switch(config-if)#ip address 192.168.3.1 255.255.255.0


5)Назначим trunk порты (подключение коммутатор-коммутатор):

Код: выделить все
Switch(config)#finterface fastEthernet 0/1
Switch(config-if)#switchport trunk encapsulation dot1q


6)Включим маршрутизацию:
Код: выделить все
Switch(config)#ip routing


7)Настроим DHCP-сервер (имеем 2 vlan-интерфейса, к которым привязаны разные подсети, нужно в каждую подсеть раздать адреса динамически с дефолтным маршрутом)

7.1)Исключаем адреса шлюзов из доступных адресов для раздачи:

Код: выделить все
Switch(config)#ip dhcp excluded-address 192.168.2.1
Switch(config)#ip dhcp excluded-address 192.168.3.1


7.2)Затем прописываем пулы адресов для раздачи:

Код: выделить все
Switch(config)#ip dhcp pool net2
Switch(dhcp-config)#network 192.168.2.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.2.1
Switch(config)#ip dhcp pool net3
Switch(dhcp-config)#network 192.168.3.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.3.1


Настройка Cisco Catalyst-2960 (L2 switch):

1)Зададим IP – адрес коммутатору:
Код: выделить все
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Switch(config-if)# no shutdown


2)Зададим шлюз коммутатору:
Код: выделить все
Switch(config)#ip default-gateway 192.168.1.1


3)Создадим vlan-ы:
Код: выделить все
Switch(config)#vlan 2
Switch(config-vlan)#name net2
Switch(config)#vlan 3
Switch(config-vlan)#name net3


4)Назначим access порты (подключение ПК-коммутатор):
Код: выделить все
Switch(config)#interface range fastEthernet 0/2-10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 2
Switch(config)#interface range fastEthernet 0/11-20
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 3


5)Назначим trunk порты (подключение коммутатор-коммутатор):
Код: выделить все
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk
Для желающих отблагодарить
SB: 4274320029755744
QIWI: +79175241450
Аватар пользователя
ROOT
Администратор
 
Сообщений: 136
Зарегистрирован: 01 авг 2011, 09:36
Откуда: Моск. обл., г. Железнодорожный

Вернуться в CISCO

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron